Email Broadcasts Stuck on "Delivering"
Incident Report for Kajabi
Resolved
This incident has been resolved.
Posted Nov 01, 2022 - 15:06 PDT
Monitoring
Email sending processes should now be up to date. If you encounter any issues of a similar vein to broadcasts stuck delivering, please contact our support team via live chat or support@kajabi.com.
Posted Nov 01, 2022 - 14:53 PDT
Investigating
We are investigating an issue affecting Broadcast sending that causes the "Your Email Broadcast is being sent" screen to hang. At this time it's unknown if it's just a UI issue or if there are deliverability delays, but we will update you as soon as we have more information to share.
Posted Nov 01, 2022 - 14:20 PDT