Notice Regarding Kajabi Support Wait Times

Incident Report for Kajabi

Resolved

This incident has been resolved.
Posted Sep 29, 2025 - 12:22 PDT

Identified

We're experiencing a high volume of inquiries and wait times may be longer than usual.

We're working to get to our Heroes as quickly as possible. In the meantime, you may be able to find an answer to your question by visiting our Help Center at https://help.kajabi.com.

We appreciate your patience and understanding.
Posted Sep 18, 2025 - 16:11 PDT