Site Availability Issues

Incident Report for Kajabi

Resolved

This incident has been resolved.
Posted Sep 18, 2026 - 11:39 PDT

Monitoring

A fix has been deployed for the site availability issues. We're closely monitoring the results to confirm full resolution and will update this page once we're confident the issue is fully resolved. Thank you for your patience throughout.
Posted Sep 18, 2026 - 11:25 PDT

Identified

We've noticed an issue with slow load times or difficulty accessing your sites. We've identified the root cause of the issue and our engineering team is actively working on a fix. We'll continue to post updates here as we make progress.
Posted Sep 18, 2026 - 11:02 PDT