Email Campaign Statistics Delay
Incident Report for Kajabi
Resolved
This incident has been resolved.
Posted Nov 27, 2020 - 12:45 PST
Monitoring
A fix has been applied and email statistic latency is improving. Continuing to monitor.
Posted Nov 27, 2020 - 12:14 PST
Investigating
We're currently investigating an issue that is causing delays in updates to email campaign statistics.
Posted Nov 27, 2020 - 11:14 PST