Amazon Web Services (AWS) has implemented a fix, and impacted services are beginning to recover. We’ll continue to monitor performance and share updates as needed.
Please note that Kajabi Experts Store is among the services affected by this issue. Our team is actively monitoring its performance to ensure full recovery and stability.
Posted Oct 20, 2025 - 02:47 PDT
Update
We are continuing to investigate this issue.
Posted Oct 20, 2025 - 00:50 PDT
Investigating
We’re currently experiencing service interruptions due to an outage with Amazon Web Services (AWS). Impacted services include Hero logins, outbound emails, automations, media uploads, live chat, and checkout. We’ll update this page as we have more information to share.
Posted Oct 20, 2025 - 00:50 PDT
This incident affected: Email (Automated Site Emails, Marketing Email Editing and Scheduling) and Checkout (Offer Checkout).