Errors Accessing or Editing Offers

Incident Report for Kajabi

Resolved

This incident has been resolved.
Posted Sep 02, 2026 - 10:40 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 02, 2026 - 09:27 PDT

Investigating

We are currently investigating reports of time outs or errors when accessing or editing Offers in the Kajabi admin.

Customer checkout is not affected, and purchases are processing normally.

Our team is actively looking into this and working as quickly as possible to resolve it.

We will post an update as soon as we have more information.
Posted Sep 02, 2026 - 08:16 PDT