Previous values appearing when changes are made in Course Content

Incident Report for Kajabi

Resolved

This incident has been resolved.
Posted Aug 14, 2026 - 13:41 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 14, 2026 - 12:30 PDT

Identified

Heroes may see previous values after saving changes in Course content. Updates are being processed and applied normally, but may not immediately display. You can refresh the page to see the updated content in the meantime.

Our engineering team is investigating and we will share another update as we have more information.
Posted Aug 14, 2026 - 10:21 PDT