Delay in reporting and statistical data in some areas of the app.

Incident Report for Kajabi

Resolved

This incident has been resolved.
Posted Aug 18, 2025 - 16:23 PDT

Identified

We're currently experiencing a delays in processing reporting and statistical data. We have identified the issue and working on implementing a solution. We'll update this status as we get more information.
Posted Aug 18, 2025 - 13:51 PDT