Slow page loads and issues accessing Kajabi

Incident Report for Kajabi

Resolved

This incident has been resolved.
Posted Jun 30, 2026 - 06:37 PDT

Monitoring

A fix has been implemented, and we are seeing the platform recover. Users are once again able to access Kajabi, and services are returning to normal. We will continue to closely monitor to ensure stability and will provide additional updates if necessary.
Posted Jun 30, 2026 - 04:38 PDT

Update

We're continuing to investigate reports of slow page loads and issues accessing Kajabi. Our engineering team is actively working to identify the root cause and restore normal performance as quickly as possible. We'll continue to provide updates as more information becomes available.
Posted Jun 30, 2026 - 04:29 PDT

Investigating

We’re currently investigating reports of slow page loads and intermittent issues accessing Kajabi. Our engineering team is actively investigating and will provide updates as more information becomes available.
Posted Jun 30, 2026 - 02:49 PDT
This incident affected: App Availability.