Email delivery delays

Incident Report for Kajabi

Resolved

This incident has been resolved.
Posted Nov 29, 2024 - 14:37 PST

Monitoring

Our email delivery vendor is experiencing delivery delays. We are continuing to monitor the situation and will update this page as additional information becomes available.

We will be monitoring to ensure emails are continuing to be delivered.
Posted Nov 29, 2024 - 09:14 PST

Update

We've had some reports of email sending being delayed. Please note that email delivery remains unaffected by these delays.

We are investigating the matter.

Thank you for your patience while we look into this.
Posted Nov 29, 2024 - 08:45 PST

Investigating

We've had some reports of email statistics not propagating to Kajabi's email reporting tool. Please note that email delivery remains unaffected by these delays.

Thank you for your patience while we look into this.
Posted Nov 29, 2024 - 06:57 PST