Email Deliverability Issues
Incident Report for Kajabi
Resolved
This incident has been resolved.
Posted Jul 19, 2024 - 08:30 PDT
Monitoring
Please follow the recommendations to resume normal email deliverability:

• Heroes who did not send any emails between Saturday, July 13th and Wednesday, July 17th, may resume sending emails after 12 PM PT tomorrow, July 18th.

• Heroes who sent any email between Saturday, July 13th and Wednesday, July 17th may resume sending emails on July 19th including resending any emails affected by the blocklist. We are working diligently through contact remediation for these Heroes and are using some additional time to ensure this work is done well.

We are happy to report that Spamhaus has delisted our domain, and email deliverability should return to normal shortly.

If you were affected by this incident and need help resending emails, please reach out to support@kajabi.com.
Posted Jul 17, 2024 - 10:14 PDT
Identified
Update:

Our email deliverability issues are the result of Kajabi being temporarily blocklisted by Spamhaus. Spamhaus is an international nonprofit organization dedicated to policing spam and phishing related activity. The blocklist affects Kajabi's ability to deliver emails to specific domains located in the European Union and Microsoft and Apple domains, and affects about 10-15% of emails sent from the Kajabi platform.

Spamhaus has communicated to us that the temporary block occurred because of a significant increase in recent phishing being sent from the Kajabi platform. Kajabi's market-leading email capabilities make the platform a target for bad actors to send phishing emails. Typically, bad actors take advantage of weak or leaked credentials (passwords) to access accounts and send phishing emails, which caused this specific incident. We are actively working closely with Spamhaus to resolve the issue as quickly as possible but do not currently have a timetable to provide to you all.

We'd like to assure our Heroes that resolving this temporary issue is of utmost priority here at Kajabi and the instant we know anything, you will know as well.

What you can do to help:

Secure Your Account:
Please help us prevent bad actors from abusing Kajabi by using strong passwords, not sharing passwords, and adopting MFA. For more information on securing your accounts, please check out this FTC Guidance https://consumer.ftc.gov/articles/creating-strong-passwords-and-other-ways-protect-your-accounts#strong.

MFA is a powerful deterrent for potential bad actors from accessing an account without the owner's consent. For more information on Kajabi MFA and how to turn it on, please visit https://help.kajabi.com/hc/en-us/articles/8293506425115-How-to-Set-Up-Multi-Factor-Authentication-MFA.

Clean Up Account's Access:
Take a moment to do an audit of every user that has access to your Kajabi account by visiting Settings / Users. If you see a User that no longer needs access, you can suspend them by clicking on the user and hitting the suspend button. This will ensure that only people you've authorized have access to your account and is an important part of account security.

Our entire team is all hands on deck to help resolve this. We'll routinely provide updates as we know more. You can subscribe to this status to stay tuned for updates.
Posted Jul 16, 2024 - 10:33 PDT
Investigating
We’ve discovered an issue impacting Kajabi’s email deliverability. We know how critical email deliverability is for your business and are working to resolve this matter as soon as possible and will provide updates as we have them. We highly appreciate your patience and understanding as we work to resolve this issue.

Subscribe to stay tuned for updates on this.
Posted Jul 15, 2024 - 11:27 PDT