Email Broadcast Delays
Incident Report for Kajabi
Resolved
This incident has been resolved.
Posted Sep 19, 2022 - 03:06 PDT
Investigating
We are currently seeing delays with email broadcast deliveries. Email broadcast deliveries may be delayed until the issue is resolved. We are monitoring the service and will provide updates as they become available.
Posted Sep 19, 2022 - 00:01 PDT