Unresponsive Pages when making a change in Kajabi
Incident Report for Kajabi
Resolved
We have identified that some Heroes are experiencing unresponsive pages in the admin when using Google Chrome.

Please update Chrome to the latest version to resolve this issue. Please reach out to support@kajabi.com for additional support or questions.
Posted Dec 04, 2024 - 08:01 PST
Update
We are still investigating the cause of the issue. If you experience an issue with unresponsive pages in Kajabi, please reach out to our support team at support@kajabi.com.
Posted Dec 03, 2024 - 16:22 PST
Investigating
Some heroes are experiencing a unresponsive page when attempting to make changes in Kajabi. We are investigating these reports and looking for the cause of the issue. We will update when we have more information here. If you are experiencing this, please contact our support team by emailing support@kajabi.com or connecting via Live Chat. We'll be glad to help!
Posted Dec 03, 2024 - 08:16 PST