Scheduled maintenance is complete and our support conversation widget is back up.
We're currently experiencing a high volume of inquiries and wait times may be a little longer than usual. We're working to get to our Heroes as quickly as possible. In the meantime, you may be able to find an answer to your question by visiting our Help Center at https://help.kajabi.com.
Posted Oct 29, 2025 - 23:45 PDT
Verifying
Scheduled maintenance is complete and our support conversation widget is back up.
We're currently experiencing a high volume of inquiries and wait times may be a little longer than usual. We're working to get to our Heroes as quickly as possible. In the meantime, you may be able to find an answer to your question by visiting our Help Center at https://help.kajabi.com.
Posted Oct 29, 2025 - 23:43 PDT
Update
Scheduled Maintenance is still in progress, taking a little longer than expected. We'll update this status when we have more information.
Posted Oct 29, 2025 - 21:12 PDT
Update
Scheduled Maintenance is still in progress. We estimate for the maintenance to complete by 9:00 PM PT.
Posted Oct 29, 2025 - 20:07 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 29, 2025 - 17:04 PDT
Scheduled
We know that world-class support is essential to your success. To deliver the faster, smarter, and more impactful experience you deserve, we are performing a major upgrade as part of our commitment to completely reimagine and elevate our Support infrastructure.
To apply these critical system upgrades, our support chat widget will be unavailable on Wednesday, October 29th, from 5-8pm PST.