Customers are unable to create custom email domains at this time
Incident Report for Kajabi
Resolved
This incident has been resolved.
Posted Dec 17, 2020 - 06:49 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 17, 2020 - 06:36 PST
This incident affected: App Availability.