PayPal Payment Processing Failures

Incident Report for Kajabi

Resolved

This incident has been resolved.
Posted Nov 21, 2024 - 05:26 PST

Investigating

One of our payment providers, PayPal, is experiencing an outage. PayPal payments are failing. We'll keep everyone posted for any updates regarding this issue.

Stripe and Kajabi Payments are fully operational.
Posted Nov 21, 2024 - 04:11 PST