Kajabi New Account Signups
Incident Report for Kajabi
Resolved
Our team has been successful in resolving this issue. All signups will now go through normally, and we're closing this incident as resolved. Thank you for choosing Kajabi and have a wonderful rest of your day.
Posted May 02, 2022 - 07:31 PDT
Investigating
We've noticed new account signups are experiencing getting stuck in the signup process. Our engineers are investigating and looking into the matter. We'll provide an update soon once our team has identified the root cause. We highly appreciate your patience at this time.
Posted May 01, 2022 - 23:46 PDT