Some heroes unable to save content in Kajabi

Incident Report for Kajabi

Resolved

This incident has been resolved.
Posted Aug 17, 2026 - 13:04 PDT

Monitoring

We received reports of errors when saving changes across multiple areas of Kajabi.

A fix has been deployed for the errors affecting saving across multiple areas of Kajabi, and saving should now be working as expected.

Our team is actively monitoring to confirm full resolution.

Heroes who continue to experience issues should try refreshing their browser, and can contact our support team if the problem persists.
Posted Aug 17, 2026 - 11:02 PDT