Errors Altering Custom Domains
Incident Report for Kajabi
Resolved
This incident has been resolved.
Posted May 08, 2023 - 18:03 PDT
Investigating
We're investigating issues connecting, removing, and editing custom domains. We will update this page as soon as we have more information to share.
Posted May 08, 2023 - 17:40 PDT