Issue displaying contacts in the contacts list

Incident Report for Kajabi

Resolved

This incident has been resolved.
Posted Dec 06, 2025 - 02:31 PST

Update

Contact data and search results are currently delayed. There is no data loss—all your information is safe. Newly created or updated contacts may take a little time to appear in your contact list. The underlying issue has been fixed, and the remaining data will finish updating over the next few hours.
Posted Dec 05, 2025 - 19:01 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 05, 2025 - 18:09 PST

Investigating

We are aware of an issue where some contacts are not being displayed in the contacts list. We are actively investigating the issue, and we will provide updates to this page as soon as possible.
Posted Dec 05, 2025 - 16:36 PST