Investigating Email Delivery Issues (Microsoft Providers)

Incident Report for Kajabi

Resolved

This incident has been resolved.
Posted Feb 25, 2026 - 13:34 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 25, 2026 - 13:13 PST

Identified

We are currently addressing a delivery delay affecting Heroes with Microsoft email addresses (Outlook, Hotmail, and Live) from receiving transactional emails. This may include emails relating to Mobile Email Confirmations, Form Submissions Created, Payment Failure Notifications, and Offer Purchase emails.

Our team is working to ensure all transactional emails are delivered. We'll update this status page when we have more information.
Posted Feb 25, 2026 - 10:31 PST