Support Email Disruption - Please Use Live Chat

Incident Report for Kajabi

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 30, 2026 - 12:25 PDT

Investigating

We’re currently experiencing an issue where support emails are not being sent from our system. Our team is actively working to resolve this as quickly as possible.
In the meantime, if you need assistance, please reach out to us via live chat for immediate support.
We appreciate your patience and will provide updates as soon as possible.
Posted Mar 30, 2026 - 09:31 PDT