A fix has been deployed for the errors affecting access to the Kajabi Feedback Portal (feedback.kajabi.com). You should now be able to log in using the Login button on the top right.
We are actively monitoring to confirm full resolution. If you continue to experience issues accessing the portal, please contact our support team at support@kajabi.com.
Posted Sep 01, 2026 - 09:01 PDT
Identified
We have identified the cause of the errors affecting access to the Kajabi Feedback Portal (feedback.kajabi.com). Our engineering team is working as quickly as possible to implement a fix. We will provide another update once the fix has been deployed.
Posted Sep 01, 2026 - 08:38 PDT
Investigating
We are currently investigating reports of errors when accessing the Kajabi Feedback Portal (feedback.kajabi.com). Some users may see a token error when attempting to load the portal. Our team is actively looking into the cause and is working as quickly as possible to resolve it. We will share another update as soon as we have more information.